docker 命令报异常permission denied的解决方案
在Linux系统中,新安装docker,输入命令,如:docker images
结果却报异常了

简单理解就是当前用户的连接被拒绝了
解决方案一:使用管理员权限,命令前加sudo
解决方案二:给当前用户加入到docker用户组中
sudo groupadd docker #添加docker用户组,这个用户组应该是已存在了sudo gpasswd -a $USER docker #将当前用户加入到docker用户组中newgrp docker #更新用户组docker
再执行 docker images

这个就可以正常使用了
补充:Docker -v 对挂载的目录没有权限 Permission denied解决办法
情况描述今天在使用docker run -d -p 9091:8080 -v /home/daniu/docker/tomcat/webapps/:/usr/local/tomcat/webapps/ --name managertomcat daniu/mytomcat
挂载路径后,进入容器
root@08066d03a043:/usr/local/tomcat# cd webapps/root@08066d03a043:/usr/local/tomcat/webapps# lsls: cannot open directory ’.’: Permission deniedroot@08066d03a043:/usr/local/tomcat/webapps#
查看webapps提示没有权限。
原因:centos7中安全模块selinux把权限禁掉了。
有三种方法解决:1.在运行时加 --privileged=true[daniu@localhost tomcat]$ docker run -d -p 9091:8080 -v /home/daniu/docker/tomcat/webapps/:/usr/local/tomcat/webapps/ --privileged=true --name managertomcat xuhaixing/mytomcatc512137b74f3366da73ff80fc1fd232cc76c95b52a4bab01f1f5d89d28185b28[daniu@localhost tomcat]$ ls2.临时关闭selinux然后再打开
[daniu@localhost tomcat]# setenforce 0[daniu@localhost tomcat]# setenforce 13.添加linux规则,把要挂载的目录添加到selinux白名单
# 更改安全性文本的格式如下chcon [-R] [-t type] [-u user] [-r role] 文件或者目录选顷不参数: -R :该目录下的所有目录也同时修改; -t :后面接安全性本文的类型字段,例如 httpd_sys_content_t ; -u :后面接身份识别,例如 system_u; -r :后面街觇色,例如 system_r执行:chcon -Rt svirt_sandbox_file_t /home/daniu/docker/tomcat/webapps/
以上为个人经验,希望能给大家一个参考,也希望大家多多支持好吧啦网。如有错误或未考虑完全的地方,望不吝赐教。
相关文章:
1. python为什么要安装到c盘2. Python使用Numpy模块读取文件并绘制图片3. Python定时从Mysql提取数据存入Redis的实现4. Python使用pycharm导入pymysql教程5. Python如何把十进制数转换成ip地址6. python点云地面点滤波(Progressive Morphological Filter)算法介绍(PCL库)7. python全栈开发语法总结8. python numpy库np.percentile用法说明9. python为Django项目上的每个应用程序创建不同的自定义404页面(最佳答案)10. Python虚拟环境virtualenv创建及使用过程图解

网公网安备