文章详情页
service mysql.server start 启动失败
浏览:275日期:2022-06-14 09:20:00
问题描述
问题解答
回答1:已解决。解决思路:讲道理mysql应该是从--defaults-file 指定的地址去读取配置文件其次读取--defaults-file-extra 指定的地方读取配置文件
这两者我都没有指定过,那么,读取的顺序应该是:
/etc/my.cnf
/etc/mysql/my.cnf
~/mysql/my.cnf
..
逐步去读取配置文件,但是启动一直报错pid文件目录找不到。然而,我/etc/my.cnf指定的pid是文件是 $base_dir目录,报错却不是这个目录。因此我估计是配置文件的读取顺序和步骤跟我想象的不一样,所以我删除了其它目录的my.cnf文件。即:删除了 /etc/mysql[my.cnf]目录
fixed。
结果解决了,但是留下一个问题,为什么首先读取的配置文件不是/etc/my.cnf文件。待了解。
回答2:试试service mysql start
相关文章:
1. mysql按照时间热度排序2. 使用weex扩展html5的项目存在ios不同版本的兼容性3. 网页爬虫 - python爬虫用BeautifulSoup爬取<s>元素并写入字典,但某些div下没有这一元素,导致自动写入下一条,如何解决?4. 导入数据库不成功5. python3.x - python多进程,不能在同一窗口吗6. javascript - 这不是对象字面量函数吗?为什么要new初始化?7. javascript - html5多个label中其中一个触发change,如何判断是哪一个出发了change8. sublime-text - sublime text 3中编译python(sublimeREPL),如何仅运行单行/选定部分9. pdo_mysql 值自增写法10. javascript - chart.js如何修改某个指定bar的颜色
排行榜

网公网安备