文章详情页
运维 - linux空间df -h和du -sh结果相差好多。。。
浏览:251日期:2024-07-03 10:15:07
问题描述
云服务器报警剩余空间不足,登陆服务器使用df -h查看情况如下:
但是在根目录使用du-sh *去查看每一个文件夹的大小的时候,发现这些文件夹的总和与31G相距甚远,请问这是为什么?(share的23G是挂载盘,在上图的 df -h里面有体现)
问题解答
回答1:它们统计的方式有所区别,相差如此之大的一种可能性是因为删除了正在被使用的文件。可以通过命令lsof|grep delete查看有哪些文件被删除但仍被程序占用。需要将这些程序重启才能将所占用的空间释放掉。
回答2:基本原因就是@vvpale所说的这样,df和du显示的磁盘空间使用情况不一致的原因及处理作为参考
回答3:两种情况1、df包括已经删除但没释放的空间,通过lsof grep deleted查看。2、某些目存在内容,但是被作为mount上的其他分区,因此此目录下的内容就看不到,但是它们都还在那里。
相关文章:
1. PC 手机兼容的 编辑器2. 编辑管理员信息时,为什么没有修改过的内容会为空?3. css3不包括4. 求救一下,用新版的phpstudy,数据库过段时间会消失是什么情况?5. javascript - 如何将一个长为365的数组对象按月份切割成12组?6. node.js - npm安装模块时,在cmd上显示的是一条白线,白线前面是一天反斜线转圈圈,然后就出现npm ERR错误了,求帮助,谢谢7. angular.js - Angular 像这种重复判断的表达式 有什么好的解决办法吗?~8. html - angularJS中switch切换开关按钮不能操作9. node.js - npm run dev报错10. mysql - SELECT 多個資料表及多個欄位
排行榜

网公网安备