文章详情页
linux - centos上安装mysql5.7
浏览:234日期:2024-07-02 13:39:47
问题描述
在我将mysql-xxx.tar.gz 解压之后,发现support-files中,没有my-default.cnf,之后按照网上以及mysql官网的安装,都会出现以下错误RROR! MySQL server PID file could not be found!之类的错误,并且my-default.cnf文件也没有出现刚刚解压后的文件如下
这个该怎么解决啊
问题解答
回答1:没有用源码装过,查了个资料,你试下有没有用: http://www.jb51.net/article/112256.htm
回答2:后来自己查看了下MySQL的官方手册,发现自5.7.5之后,my-default.cnf,文件就不存在了,按照官方手册安装,还有一个问题,就是mysql.server,启动时会报错,提示什么pid不存在之类对的,这时候执行`ps aux|grep mysql
相关文章:
1. java - 做一个视频播放器,想实现一个功能,如果3秒不点击屏幕任何,则下方一个界面布局(显示按钮那些的)自动消失。2. javascript - js中数组的undefined为什么不会被遍历3. thinkphp中Controller里面使用Request::File(’image’);4. 编辑管理员信息时,为什么没有修改过的内容会为空?5. java 如何列出jar包中jar包里的所有文件和目录?6. html - angularJS中switch切换开关按钮不能操作7. PC 手机兼容的 编辑器8. javascript - 如何将一个长为365的数组对象按月份切割成12组?9. mysql - 看这条sql有可能被注入吗10. 求救一下,用新版的phpstudy,数据库过段时间会消失是什么情况?
排行榜

网公网安备